Understanding PHP incompatibility

The PHP Compatibility Checker allows you to quickly find out if your website is compatible with the latest PHP versions

The PHP Compatibility Checker has a status indicator:

  • A green status confirms that the website is compatible and you may safely proceed with the upgrade
  • If the tool is not able to determine with certainty that the site is compatible, the status will be orange.

For more information on why your website may not be compatible, select Download CSV Report to generate a compatibility report. This report can be shared with your web developer.

Popular CMSes:

If you are running any of the following versions of these popular CMSes, in most cases, it should be safe to upgrade your PHP version:

WordPress 5.2 (or above)
Drupal 8.7.1 (or above)
Joomla! 3.9.6 (or above)

Note: You would need to ensure that any plugins you are using are compatible with the latest PHP version. Please refer to the compatibility report for more detail.

FAQ:

If it is likely that my website is compatible with the latest PHP version, why is it indicated as incompatible?

While the version of CMS you are using may be compatible with PHP 8.0 or later, the plugins or bespoke software you are using may not be. We recommend that your web developer review the error messages in the compatibility report before upgrading.

If any site components are not working after the upgrade, you can roll back the changes by downgrading to the previous version of PHP via the PHP Config tool in konsoleH. Be sure to fix the broken components to ensure your site will be compatible with PHP 8.0 and later.

Why do I need to upgrade my PHP version?

All major content management systems recommend PHP 8.0 and above due to the performance and security benefits. Using an older version of PHP leaves your site vulnerable to malicious activities from hackers, as security updates for this version have reached end of life. 

I don’t know how to interpret the compatibility report provided. What do I do know?

We recommend that you share the compatibility report with your web developer who will be able to interpret the report and make the necessary changes. 

I haven’t experienced problems with the older version of WordPress that I am currently using. Do I still need to upgrade?

It is best practice to make use of the latest version of PHP so that your website is not vulnerable to malicious activities from hackers.