The PHP Compatibility Checker is a tool available in konsoleH that allows you to quickly find out if your website is compatible with PHP 7.2.

Check if your website is compatible with PHP 7.2:

  1. Browse to konsoleH and log in at Admin or Domain level
  2. If Admin level: Select or search for a domain name in the Hosting Services tab
  3. Select Manage Services on the left-hand menu
  4. Below that select Configuration > PHP Config 
  5. Click Run Check Now

The PHP Compatibility Checker has a status indicator:

  • A green/ Yes status confirms that the website is compatible with PHP 7.2 and you may safely proceed with the upgrade.
  • If the tool is not able to determine with certainty that the site is compatible, the status will be orange/ Unconfirmed.

For more detailed information, simply select Download CSV Report to download a compatibility report. We recommend that you share the compatibility report with your web developer who will be able to interpret the report and make the necessary changes before upgrading.

Change your PHP version in konsoleH:

  1. Select the drop-down option next to PHP version.
  2. Select your choice of version
  3. Select Save

The upgrade will be completed automatically.

After upgrading to PHP 7.2, if any errors are found, you can simply downgrade back to the older version by following the same steps listed above. 

* Note: The option to roll back to PHP versions 5.6 and 7.0 will no longer be available from early November. 

While support for PHP 7.1 is expected until the end of 2019, we encourage you to take this opportunity to upgrade to PHP 7.2.

 

  • Did you find this article helpful?
  • YesNo
Do you need further assistance? Contact us